<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
  <head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>PBL Junior High School track athletes compete at Unity Invite | Paxton Record</title>
    <meta http-equiv="content-language" content="en" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<link rel="shortcut icon" href="http://www.paxtonrecord.net/sites/all/files/favicon.ico" type="image/x-icon" />
<meta name="keywords" content="Champaign,Urbana,Danville,Paxton,Rantoul,Mahomet,Monticello,Tuscola,East Central Illinois,University of Illinois at Urbana-Champaign,News" />
<meta name="copyright" content="Copyright (c) 2015 The News-Gazette, Inc." />
<meta name="description" content="UNITY JUNIOR HIGH INVITEAt Tolono7th-grade boysTeam scores1. Unity, 99; 2. North Ridge, 92; 3. Paxton-Buckley-Loda, 73; 4. Jefferson, 64; 5. St. Joseph, 53; 6. Tuscola East Prairie, 25; 7. Edison, 13; 8. Hoopeston Area, 11.100-meter dash1. Daniel Lacy (JEFF) 12.22; 2. Ja&#039;Marion Clark (NR) 12.68; 3." />
    <link type="text/css" rel="stylesheet" media="all" href="http://www.paxtonrecord.net/sites/all/modules/custom/custom_node/custom_node.css?M" />
<link type="text/css" rel="stylesheet" media="all" href="http://www.paxtonrecord.net/sites/all/modules/custom/custom_blocks/custom_blocks.css?M" />
<link type="text/css" rel="stylesheet" media="all" href="http://www.paxtonrecord.net/sites/all/files/css/css_4c811ab12f645c4a1d308e21796fa778.css" />
<link type="text/css" rel="stylesheet" media="screen,projection" href="http://www.paxtonrecord.net/sites/all/files/css/css_9191233ab7700e55d1a72b7e4d83f339.css" />
<link type="text/css" rel="stylesheet" media="print" href="http://www.paxtonrecord.net/sites/all/files/css/css_920d03fcfa8b11485f13c629f0afe4ea.css" />
<!--[if lte IE 7]>
        <link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/ng_weather/css/weather_ie7.css" media="all" />
      <![endif]-->        <script type="text/javascript" src="http://www.paxtonrecord.net/sites/all/files/js/js_3658f342a71ef53fa49973fe3010abaa.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","uc_ajax_cart":{"CALLBACK":"\/uc_ajax_cart\/add\/item","SHOW_CALLBACK":"\/uc_ajax_cart\/show","CART_LINK_CALLBACK":"\/uc_ajax_cart\/addlink","BLOCK_UI":2,"TIMEOUT":2500,"UPDATE_CALLBACK":"\/uc_ajax_cart\/update","UPDATE":0,"CART_VIEW_ON":0,"SHOW_VIEW_CALLBACK":"\/uc_ajax_cart\/show-cart-view","TRACK_CLOSED_STATE":0,"INITIAL_CLOSED_STATE":0,"CART_PANE_EFFECT":0,"CART_PANE_EFFECT_DURATION":200,"HIDE_CART_OPERATIONS":false,"COLLAPSIBLE_CART":0,"CART_OPERATION":"Cart","ADD_TITLE":"Please wait","ADD_MESSAGES":["Adding product to cart..."],"REMOVE_TITLE":"Please wait","REMOVE_MESSAGES":["Removing product from cart..."],"UPDATE_TITLE":"Please wait","UPDATE_MESSAGES":["Updating cart..."]},"ws_fl":{"width":92,"height":"21"},"ws_gpo":{"type":"medium","counter":true},"jPlayer":{"swfPath":"\/sites\/all\/libraries\/jplayer","autoPlay":0},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"CToolsUrlIsAjaxTrusted":{"\/sports\/prep-sports\/2018-05-05\/pbl-junior-high-school-track-athletes-compete-unity-invite.html?destination=node%2F1615165":true,"\/sports\/prep-sports\/2018-05-05\/pbl-junior-high-school-track-athletes-compete-unity-invite.html":true}});
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","/sites/all/files/googleanalytics/analytics.js?M","ga");ga("create", "UA-4954131-28", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
    
    <!--this code applies superfish style to the network, network lower, and user options menus-->
    <script type="text/javascript">
      $(document).ready(function() {
        $("#network-menu ul.menu").superfish();
        $("#network-menu-lower ul.menu").superfish();
        $("#user-account ul.menu").superfish();
      });
    </script>
  </head>

  <body id="body-specs">
    <div id="wrapper">
      <div class="nav-bar-wrapper">
       <div id="network-nav-bar">
                    <div id="network-menu">
                          <div id="block-menu-menu-ng-network" class="block block-menu region-odd odd region-count-1 count-1">

  
  <div class="content"><ul class="menu"><li class="expanded first last"><a href="/" title="Our sites">Our Sites</a><ul class="menu"><li class="expanded first"><a href="http://www.news-gazette.com" title="">The News-Gazette</a><ul class="menu"><li class="leaf first"><a href="http://digital.news-gazette.com" title="Digital Services">Digital Services</a></li>
<li class="leaf last"><a href="http://www.news-gazette.com/eedition" title="eEdition">eEdition</a></li>
</ul></li>
<li class="leaf"><a href="http://www.news-gazette.com/sports/illini-sports" title="">IlliniHQ</a></li>
<li class="leaf"><a href="http://www.wdws.com/" title="">NewsTalk 1400 WDWS-AM</a></li>
<li class="leaf"><a href="http://www.whms.com/" title="">Lite Rock 97.5 WHMS</a></li>
<li class="leaf"><a href="http://www.1079wkio.com" title="">107.9 WKIO</a></li>
<li class="expanded"><a href="http://www.news-gazette.com/news-gazette-community-newspapers.html" title="Community News">Community News</a><ul class="menu"><li class="leaf first"><a href="http://www.county-star.com/" title="">County Star</a></li>
<li class="leaf"><a href="http://www.the-independent-news.com/" title="">The Independent News</a></li>
<li class="leaf"><a href="http://www.leaderlandnews.com/" title="">The Leader</a></li>
<li class="leaf"><a href="http://www.mcitizen.com/" title="">Mahomet Citizen</a></li>
<li class="leaf"><a href="http://www.paxtonrecord.net/" title="">Paxton Record</a></li>
<li class="leaf"><a href="http://www.journal-republican.com/" title="">Piatt County Journal-Republican</a></li>
<li class="leaf last"><a href="http://www.rantoulpress.com/" title="">Rantoul Press</a></li>
</ul></li>
<li class="expanded last"><a href="http://www.news-gazette.com/news-gazette-magazines.html" title="">Magazines</a><ul class="menu"><li class="leaf first"><a href="http://www.athomeillinois.com" title="At Home ">At Home </a></li>
<li class="leaf last"><a href="http://www.centralillinoisbusiness.com/" title="">Central Illinois Business</a></li>
</ul></li>
</ul></li>
</ul></div>
  
</div>
           </div><!--close network_menu-->
         
         
         <div id="network-login-area">
                        <div id="nav-bar-text">
                   <ul>
                       <li><a href="/user/login?destination=sports/prep-sports/2018-05-05/pbl-junior-high-school-track-athletes-compete-unity-invite.html">LOGIN</a></li>
                       <li><a href="/user/register" title="Create new account.">Create new account</a></li>
					   <li><a href="/user/password" title="Request new password via e-mail.">Login problems?</a></li>
                   </ul>
             </div><!--closes create account-->         </div><!--/network-login-area-->
         
                  
          
         <ul class="social-network-icons">
                      <li><a href="http://www.facebook.com/pages/Paxton-Record/128840960595021" target="_blank"><img src="http://www.paxtonrecord.net/sites/all/themes/custom/cms_desktop/images/icons/facebook_icon.gif" alt="Facebook" /></a></li>
                      
         </ul>
                  
         <div id="header-search-field">
                        <form action="/sports/prep-sports/2018-05-05/pbl-junior-high-school-track-athletes-compete-unity-invite.html"  accept-charset="UTF-8" method="post" id="search-theme-form">
<div><div id="search" class="container-inline">
  <div class="form-item" id="edit-search-theme-form-1-wrapper">
 <label for="edit-search-theme-form-1">Search: </label>
 <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-1" size="15" value="" class="form-text search-theme-form-text-input" />
</div>
<input type="image" name="" value="Search" id=""  class="form-submit" src="http://www.paxtonrecord.net/sites/all/modules/custom/search_content/images/mag_glass.gif" alt="Click to search" title="Click to search" />
<a href="#" onclick="return false;"><img class="search-options-arrow" src="/sites/all/modules/custom/search_content/images/down_arrows.gif" /></a><div class="search-options-dropdown"><label>Search in:</label> <div class="form-item" id="edit-content-type-wrapper">
 <select name="content-type" class="form-select" id="edit-content-type" ><option value="" selected="selected">Everything</option></select>
</div>
</div><input type="hidden" name="form_build_id" id="form--YVVFwdTTAzkjmkTF6qOItSz9IT63m6rNYi1lJBGCXw" value="form--YVVFwdTTAzkjmkTF6qOItSz9IT63m6rNYi1lJBGCXw"  />
<input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
                    </div><!--closes header search field-->
        </div><!--closes nav-bar-->
      </div><!--/nav-bar-wrapper-->
      
      <div id="header"> <!--includes logo and menu-->
        <div id="main-logo">
          <div id="business_directory_search">
                      </div>
          <a href = "/"><img src="http://www.paxtonrecord.net/sites/all/themes/custom/cms_desktop/pr_desktop/images/ford_count_logo.png" alt = "Ford County Record"  /></a>
          <a href = "/"><img id="cn-logo" src="http://www.paxtonrecord.net/sites/all/themes/custom/cms_desktop/pr_desktop/images/cn_logo.gif" alt = "The News-Gazette Comunity Newspapers" /></a>
        </div><!--/main-logo--> 
        <div id="site-slogan">
             
        </div>
      </div> <!--closes header-->   
 
      <div class="container">
        <div class="span-24">
          <div id="menu">
                          <!-- Primary || Superfish -->
              <div id="superfish">
                <div id="superfish-inner">
                  <ul class="menu"><li class="expanded first"><a href="/category/news" title="News">News</a><ul class="menu"><li class="leaf first"><a href="/category/news/arts-and-entertainment" title="Arts and Entertainment">Arts and Entertainment</a></li>
<li class="leaf"><a href="/category/news/business" title="Business">Business</a></li>
<li class="leaf"><a href="/category/news/courts-police-and-fire" title="Courts, Fire, and Police">Courts, Fire, and Police</a></li>
<li class="leaf"><a href="/category/news/education" title="Education">Education</a></li>
<li class="leaf"><a href="/category/news/health" title="Health">Health</a></li>
<li class="leaf last"><a href="/category/news/politics-and-government" title="Politics and Government">Politics and Government</a></li>
</ul></li>
<li class="leaf"><a href="/category/sports" title="Sports">Sports</a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries">Obituaries</a></li>
<li class="collapsed"><a href="/classified" title="Classified Ads">Classified Ads</a></li>
<li class="leaf"><a href="/pr-community-links" title="Community Links">Community Links</a></li>
<li class="leaf"><a href="/subscribe-paxton-record.html" title="Subscription Information">Subscribe</a></li>
<li class="leaf"><a href="/paxton-forms.html" title="Announcement Forms">FORMS</a></li>
<li class="leaf"><a href="/calendar" title="Upcoming Events">Events</a></li>
<li class="expanded last"><a href="/contact" title="Contact Us">Contact</a><ul class="menu"><li class="leaf first"><a href="/paxton-feedback.html" title="Feedback Form">Feedback Form</a></li>
<li class="leaf last"><a href="/contact" title="Contact Us">Contact Us</a></li>
</ul></li>
</ul>                </div><!-- / inner -->
              </div><!-- /primary || superfish -->
                      </div><!--closes menu bar-->
                  </div><!--closes header-->
        
        <div id="content-wrapper" class="span-24"><!--holds center and right col divs together-->
          <!--col class changed to span-16-plus, was span-15, DD-->
          <div id="main-content" 
            class="span-16-plus">
            <div class="breadcrumb"><a href="/">Home</a> » <a href="/category/sports">Sports</a> » <a href="/category/sports/prep-sports">Prep Sports</a> » <a href="/category/sports/prep-sports/track-and-field">Track and Field</a></div><h2>PBL Junior High School track athletes compete at Unity Invite</h2>           
                          
  <div id="node-1615165" class="node">
     
        
    
  <span class="submitted"><div class="submitted"><span class="timestamp">Sat, 05/05/2018 - 8:12pm</span> | <span class="authors"><a href="/author/ford-county-record">The Ford County Record</a></span></div></span>
  
    
      <div id="social-media-widgets">
      <a href="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;layout=button_count&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;width=92&amp;height=21&amp;font=&amp;locale=" title="I Like it" class="service-links-facebook-like" rel="nofollow"><span style="display:none;">Facebook Like</span></a><a href="http://www.paxtonrecord.net/sports/prep-sports/2018-05-05/pbl-junior-high-school-track-athletes-compete-unity-invite.html" title="Plus it" class="service-links-google-plus-one" rel="nofollow"><span style="display:none;">Google Plus One</span></a><a href="http://twitter.com/share?url=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;count=horizontal&amp;via=&amp;text=PBL%20Junior%20High%20School%20track%20athletes%20compete%20at%20Unity%20Invite&amp;counturl=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html" class="twitter-share-button service-links-twitter-widget" title="Tweet This" rel="nofollow"><span style="display:none;">Tweet Widget</span></a>    </div>
    
  <div class="content">
    <div>UNITY JUNIOR HIGH INVITE</div>
<div>At Tolono</div>
<div>7th-grade boys</div>
<div>Team scores</div>
<div>1. Unity, 99; 2. North Ridge, 92; 3. Paxton-Buckley-Loda, 73; 4. Jefferson, 64; 5. St. Joseph, 53; 6. Tuscola East Prairie, 25; 7. Edison, 13; 8. Hoopeston Area, 11.</div>
<div>100-meter dash</div>
<div>1. Daniel Lacy (JEFF) 12.22; 2. Ja'Marion Clark (NR) 12.68; 3. Michael McDaniel (JEFF) 13.43; 4. Matt Brown (UNITY) 13.48; 5. Josh Wilson (EDI) 14.15.</div>
<div>200-meter dash</div>
<div>1. Antuan Lee (NR) 26.75; 2. Jordan Griggs (JEFF) 27.21; 3. Richland Dandridge (NR) 27.58; 4. Matt Brown (UNITY) 27.73; 5. Josh Wilson (EDI) 29.29.</div>
<div>400-meter dash</div>
<div>1. Dalton Jones (PBL) 1:01.37; 2. Andrew Hemming (JEFF) 1:01.42; 3. Matthew Thomas (NR) 1:02.74; 4. Ben Hornaday (TUS) 1:05.87; 5. Ethan Reifsteck (UNITY) 1:08.38.</div>
<div>800-meter run</div>
<div>1. Braden Lane (UNITY) 2:32.33; 2. Andrew Hemming (JEFF) 2:34.8; 3. Peyton Wendell (JEFF) 2:35.07; 4. Breandan Bachert (UNITY) 2:35.18; 5. Nick Bonn (EDI) 2:47.16; 6. Landen Barfield (PBL) 2:49.23.</div>
<div>1,600-meter run</div>
<div>1. Braden Lane (UNITY) 5:21.72; 2. Payton Wendell (JEFF) 5:21.77; 3. Spencer Wilson (STJ) 5:33.5; 4. Isaac Ruggieri (UNITY) 5:34.37; 5. Carson Maroon (STJ) 5:40.16.</div>
<div>PBL results -- 8. Landen Barfield, 6:01.71; 9. Jake Swan, 6:06.87.</div>
<div>100-meter hurdles</div>
<div>1. Matthew Thomas (NR) 18.07; 2. Antuan Lee (NR) 19.88; 3. Brandon Graven (UNITY) 20.09; 4. Eric Vlachovich (UNITY) 21.54; 5. Josh Wilson (EDI) 21.93; 6. Ethan Donaldson (PBL) 22.13.</div>
<div>4x100 relay</div>
<div>1. Jefferson, 54.7; 2. Unity, 57.93; 3. St. Joseph, 1:00; 4. Hoopeston Area, 1:01.27; 5. Edison, 1:03.84.</div>
<div>4x200 relay</div>
<div>1. North Ridge, 1:48.82; 2. Tuscola East Prairie, 2:09.99; 3. Unity, 2:14.86; 4. Hoopeston Area, 2:21.58; 5. Edison, 2:24.2.</div>
<div>4x400 relay</div>
<div>1. St. Joseph, 4:17.87; 2. PBL (Dalton Jones, Aiden Johnson, Jami Lee, Jonathan Craig), 4:29.91; 3. Unity, 4:45.48; 4. Tuscola East Prairie, 5:09.5; 5. Hoopeston Area, 5:27.32.</div>
<div>High jump</div>
<div>1. Braden Lane (UNITY) 4-10; 2. Ja'Marion Clark (NR) 4-8; 3. Aiden Johnson (PBL) 4-8; 4. Aidan Porter (UNITY) 4-4; 5. Jackson Greer (STJ) 4-4; 6. Jami Lee (PBL) 4-2.</div>
<div>Long jump</div>
<div>1. Ja'Marion Clark (NR) 15-5; 2. Antuan Lee (NR) 15-4; 3. Aiden McCorkle (STJ) 14-10; 4. Tyler Burch (STJ) 14-9 1/2; 5. Matt Brown (UNITY) 14-4.</div>
<div>Shot put</div>
<div>1. Kendall Swanson (PBL) 37-2 1/2; 2. Kayden Snelling (PBL) 34-11 1/2; 3. Chris Boyd (TUS) 29-7 1/2; 4. Hunter Duncan (UNITY) 29-2; 5. Mason Jones (TUS) 26-4 1/2.</div>
<div>Discus</div>
<div>1. Kayden Snelling (PBL) 107-9; 2. Kendall Swanson (PBL) 100-3; 3. Brock Trimble (STJ) 100-0; 4. Bryce Helfrich (STJ) 92-11; 5. Jacob Bishoff (UNITY) 82-2.</div>
<div>Pole vault</div>
<div>1. Matthew Thomas (NR) 7-9; 2. Jack Bouse (PBL) 6-9; 3. Brayden Long (STJ) 6-9; 4. Kobe Clark (UNITY) 6-3; 5. Eric Vlachovich (UNITY) 5-9.</div>
<div>8th-grade boys</div>
<div>Team scores</div>
<div>1. Jefferson, 89; 2. Unity, 66; 3. North Ridge, 62; 3. Paxton-Buckley-Loda, 62; 5. Tuscola East Prairie, 56; 6. St. Joseph, 40; 7. Hoopeston Area, 32; 8. Edison, 26.</div>
<div>100-meter dash</div>
<div>1. Kemoni McCullough (JEFF) 12.4; 2. Deeken Summitt (NR) 12.67; 3. David Willis (EDI) 12.68; 4. Kamerin Cade (HA) 12.87; 5. Braylon Peacock (JEFF) 13.2.</div>
<div>PBL results -- 10. Carson Rigsby, 13.87.&nbsp;</div>
<div>200-meter dash</div>
<div>1. Deeken Summitt (NR) 26.33; 2. Kamerin Cade (HA) 26.6; 3. Rahmello Law (JEFF) 26.77; 4. Jonny Poulter (STJ) 26.78; 5. Peyton Armstrong (TUS) 26.82.</div>
<div>PBL results -- 8. Landon Daniels, 29.52.</div>
<div>400-meter dash</div>
<div>1. Ethan Vanliew (STJ) 58.06; 2. Logan Wallace (TUS) 1:00.76; 3. Gary Lee Jr. (NR) 1:03.08; 4. Shane Ogden (UNITY) 1:03.56; 5. John Blakely (NR) 1:03.9.</div>
<div>PBL results -- 7. Garrett Sanders, 1:05.77; 9. Zach Lundquist, 1:08.37.</div>
<div>800-meter run</div>
<div>1. Jesse Barfield (PBL) 2:25.23; 2. Alexander Geissler (JEFF) 2:25.45; 3. Ben Brown (HA) 2:30.04; 4. Thomas Cler (UNITY) 2:30.86; 5. Gunveer Singh (JEFF) 2:31.34.</div>
<div>1,600-meter run</div>
<div>1. Ryder James (PBL) 4:51.32; 2. Alexander Giessler (JEFF) 5:13.05; 3. Eli Mock (STJ) 5:25.89; 4. Thomas Cler (UNITY) 5:29.96; 5. Grant Garrison (STJ) 5:34.6.</div>
<div>100-meter hurdles&nbsp;</div>
<div>1. Cole Newell (UNITY) 18.56; 2. Hamzah Hanif (EDI) 18.84; 3. Will Thompson (UNITY) 20.16; 4. Caleb Haste (TUS) 20.96; 5. Braden Clampitt (STJ) 21.1.</div>
<div>4x100 relay</div>
<div>1. Jefferson, 49.74; 2. Edison, 51.82; 3. North Ridge, 51.84; 4. PBL (Keagan Busboom, Tyler Smith, Mason Bruns, Landon Daniels), 52.67; 5. Tuscola East Prairie, 1:00.43.</div>
<div>4x200 relay</div>
<div>1. North Ridge, 1:44.4; 2. Jefferson, 1:45.4; 3. Tuscola East Prairie, 1:58.01; 4. Unity, 2:05.17; 5. Hoopeston Area, 2:18.08.</div>
<div>4x400 relay</div>
<div>1. Jefferson, 4:02.43; 2. PBL (Keagan Busboom, Daniel Busby, Jesse Barfield, Ryder James), 4:04.97; 3. St. Joseph, 4:06.37; 4. North Ridge, 4:27.89; 5. Tuscola East Prairie, 4:39.68.</div>
<div>High jump</div>
<div>1. Rahmello Law (JEFF) 5-4; 2. Mason Bruns (PBL) 5-2; 3. Ian Buchanan (TUS) 5-0; 4. Clayton Jamison (UNITY) 4-10; 4. Deeken Summitt (NR) 4-10.</div>
<div>Long jump</div>
<div>1. Ricky Dandridge (NR) 17-3; 2. Kamerin Cade (HA) 16-9; 3. Peyton Armstrong (TUS) 16-7 1/2; 4. Jacob Martin (HA) 16-0; 5. Ethan Vanliew (STJ) 15-10 1/2.</div>
<div>Shot put</div>
<div>1. Peyton Armstrong (TUS) 38-9; 2. Brandon Knight (PBL) 36-6; 3. Liam Alt (UNITY) 36-2; 4. Reed Vankeuren (JEFF) 35-4; 5. Mason Holmes (TUS) 33-7 1/2.</div>
<div>Discus</div>
<div>1. Reed Vankeuren (JEFF) 120-3 1/2; 2. Liam Alt (UNITY) 115-11; 3. Haven Hatfield (TUS) 109-7; 4. Brandon Knight (PBL) 99-10; 5. Dalton Eades (TUS) 99-7 1/2.</div>
<div>PBL results -- 8. Evan Donaldson, 80-8.</div>
<div>Pole vault</div>
<div>1. Carson Kleparski (UNITY) 11-4; 2. Cameron Grohler (PBL) 9-3; 3. Charles Mabry (STJ) 8-3; 4. Shane Ogden (UNITY) 8-3; 5. Tyler Smith (PBL) 7-9.</div>
<div>7th-grade girls&nbsp;</div>
<div>Team scores</div>
<div>1. Unity, 161; 2. Jefferson, 67; 3. St. Joseph, 50; 4. Paxton-Buckley-Loda, 43; 5. Tuscola, 42; 5. North Ridge, 33; 6. North Ridge, 33; 7. Hoopeston Area, 28; 8. Edison, 9.</div>
<div>100-meter dash</div>
<div>1. Tazzariah Wesly (JEFF) 13.79; 2. Lauren Miller (UNITY) 13.86; 3. Kayla Nelson (UNITY) 13.93; 4. Rickyah Lane (NR) 14.11; 5. Loreal Allen (JEFF) 14.38.</div>
<div>200-meter dash</div>
<div>1. Lauren Miller (UNITY) 28.65; 2. Kayla Nelson (UNITY) 29.08; 3. Madiyson Schrad (JEFF) 29.37; 4. Brielle Crose (HA) 29.58; 5. Ella Boyer (TUS) 30.88.</div>
<div>400-meter dash</div>
<div>1. Mia Hausmann (TUS) 1:06.59; 2. Gety Lauria (JEFF) 1:10.43; 3. Brooklyn Sweikar (JEFF) 1:10.81; 4. Lacie Breymeyer (HA) 1:10.93; 5. Anna Clark (UNITY) 1:11.63.</div>
<div>PBL results -- 7. Cadence Neal, 1:13; 8. Morgan Uden, 1:15.65.</div>
<div>800-meter run</div>
<div>1. Danica Wrobel (UNITY) 2:38.6; 2. Raegen Stringer (UNITY) 2:39.48; 3. Brooklyn Sweikar (JEFF) 2:47.44; 4. Jody Domingo (JEFF) 2:53.7; 5. Kyla Canales (EDI) 2:55.42.</div>
<div>PBL results -- 8. Ellie Paul, 3:04.44; 10. Mackenzie Swan, 3:04.96.</div>
<div>1,600-meter run</div>
<div>1. Danica Wrobel (UNITY) 5:34.99; 2. Raegen Stringer (UNITY) 5:35.4; 3. Alexis Putnam (PBL) 6:13.64; 4. Kyla Canales (EDI) 6:20.13; 5. Helene Jones (STJ) 6:32.16.</div>
<div>100-meter hurdles</div>
<div>1. Brielle Crose (HA) 19.19; 2. Bri Richie (UNITY) 19.36; 3. Olivia Tervin (STJ) 19.58; 4. Katlyn Baker (STJ) 20.06; 5. Makhia Colunga (HA) 20.51; 6. Brooke Kleinert (PBL) 20.98.</div>
<div>4x100 relay</div>
<div>1. North Ridge, 55.08; 2. Unity, 55.23; 3. Hoopeston Area, 58.55; 4. St. Joseph, 1:00.07; 5. Tuscola, 1:01.84.</div>
<div>4x200 relay</div>
<div>1. Tuscola, 2:01.75; 2. St. Joseph, 2:07.47; 3. Unity, 2:09.68; 4. Jefferson, 2:10.41; 5. Hoopeston Area, 2:16.85.</div>
<div>4x400 relay</div>
<div>1. Tuscola, 4:42.01; 2. Unity, 4:47.3; 3. PBL (Trixie Johnson, Jordyn Goss, Averi Garrett, Estrella Landeros), 4:48.85; 4. North Ridge, 4:55.12; 5. Jefferson, 5:06.28.</div>
<div>High jump</div>
<div>1. Lauren Miller (UNITY) 4-7; 2. Katey Moore (UNITY) 4-4; 3. Madiyson Schrad (JEFF) 4-0; 4. Gracie Johnson (TUS) 3-10; 5. Avery Loschen (JEFF) 3-10; 6. Brooke Kleinert (PBL) 3-8.</div>
<div>Long jump</div>
<div>1. Kayla Nelson (UNITY) 13-9; 2. Rickyah Lane (NR) 13-7; 3. Corielle Moore (NR) 13-4; 4. Shayne Immke (STJ) 12-10 12/; 5. Chloe Harper (STJ) 12-8 1/2; 6. Averi Garrett (PBL) 12-5 1/2.&nbsp;</div>
<div>Shot put</div>
<div>1. Emily Robidoux (PBL) 25-5 1/2; 2. Maggie Ward (STJ) 25-3; 3. Arwen Lange (JEFF) 23-8; 4. Mary Bryant (UNITY) 23-7; 5. Harley Woodard (TUS) 23-2 1/2.</div>
<div>PBL results -- 14. Leah Eyre, 15-7.</div>
<div>Discus</div>
<div>1. Emily Robidoux (PBL) 80-5; 2. Mary Bryant (UNITY) 64-5; 3. Maggie Ward (STJ) 64-3; 4. Olivia Baltzell (STJ) 62-2 1/2; 5. Marley Good (TUS) 62-2.</div>
<div>PBL results -- 12. Leah Eyre, 41-2.</div>
<div>Pole vault</div>
<div>1. Caelyn Kleparski (UNITY) 7-9; 2. Maddy Swisher (UNITY) 6-9; 3. Kate Wilson (PBL) 6-3; 4. Brooke Gardner (JEFF) 5-9; 5. Bailey Luebchow (PBL) 5-9.</div>
<div>8th-grade girls</div>
<div>Team scores</div>
<div>1. Unity, 104; 2. St. Joseph, 77; 3. Jefferson, 72; 4. North Ridge, 70; 5. Paxton-Buckley-Loda, 51; 6. Hoopeston Area, 49; 7. Tuscola, 6; 8. Edison, 3.</div>
<div>100-meter dash</div>
<div>1. Kymia Williams (NR) 13.9; 2. Tharija Rose (NR) 13.95; 3. Sam Cable (HA) 14.18; 4. Mia DeJesus (JEFF) 14.33; 5. Ady Jones (HA) 14.4.</div>
<div>PBL results -- 13. Jacey Parrish, 16.5.</div>
<div>200-meter dash</div>
<div>1. Kymia Williams (NR) 29.44; 2. Ady Jones (HA) 29.52; 3. Ashyln Perry (JEFF) 29.89; 4. Amaya Edwards (JEFF) 30.2; 5. Grace Renfrow (UNITY) 30.85.</div>
<div>PBL results -- 10. Macie Wright, 32.41.</div>
<div>400-meter dash</div>
<div>1. Hope Rajlich (STJ) 1:07.76; 2. Gurveena Singh (JEFF) 1:08.7; 3. Lucy Lugo (HA) 1:08.82; 4. Destiny Williamson (UNITY) 1:09.65; 5. Aniya Parker (NR) 1:11.55.</div>
<div>PBL results -- 10. Jordan Parrish, 1:14.45.</div>
<div>800-meter run</div>
<div>1. Katelyn Allen (UNITY) 2:39.17; 2. Erica Woodard (UNITY) 2:46.24; 3. Kelsey Martlage (STJ) 2:47.99; 4. Gurveena Singh (JEFF) 2:50.28; 5. Natalie Porter (NR) 2:53.31.</div>
<div>1,600-meter run</div>
<div>1. Harper Hancock (UNITY) 5:56.05; 2. Emma Stratton (UNITY) 6:05.16; 3. Ava Knap (STJ) 6:19.19; 4. Allison Pickett (HA) 6:31.64; 5. Maaike Niekerk (EDI) 6:32.14.</div>
<div>100-meter hurdles</div>
<div>1. Lynae Ward (NR) 17.42; 2. Lillie Frichtl (PBL) 19.26; 3. Katelyn Allen (UNITY) 19.54; 4. Angie Chahine (STJ) 19.66; 5. Sam Cable (HA) 19.68.</div>
<div>4x100 relay</div>
<div>1. North Ridge, 54.21; 2. Unity, 56.46; 3. Hoopeston Area, 56.56; 4. PBL (Brooke Kleinert, Macie Wright, Averi Garrett, Estrella Landeros), 58.26; 5. Jefferson, 58.57.</div>
<div>4x200 relay</div>
<div>1. Jefferson, 1:57.76; 2. St. Joseph, 1:57.86; 3. PBL (Lillie Frichtl, Maisy Johnson, Lorena Arnett, Hope Johnson), 1:59.19; 4. Tuscola, 2:14.39; 5. Unity, 2:19.38.</div>
<div>4x400 relay</div>
<div>1. St. Joseph, 4:37.94; 2. Unity, 4:42.78; 3. Jefferson, 4:43.95; 4. PBL (Hope Johnson, Maisy Johnson, Jordan Parrish, Lorena Arnett), 4:47.05; 5. North Ridge, 4:51.55.</div>
<div>High jump</div>
<div>1. Audrey Remole (UNITY) 4-8; 2. Mia DeJesus (JEFF) 4-6; 3. Angie Chahine (STJ) 4-6; 4. Kate Yahnke (JEFF) 4-4; 5. Alyssa Hamilton (STJ) 4-4.</div>
<div>Long jump</div>
<div>1. Mallorie Sarneckle (STJ) 13-9; 2. Bailey Rice (UNITY) 13-2 1/2; 3. Grace Renfrow (UNITY) 13-2; 4. Lucy Lugo (HA) 11-11; 5. Payton Armstrong (HA) 11-9 1/2.</div>
<div>Shot put</div>
<div>1. Makenna Ecker (PBL) 28-10 1/2; 2. Lynae Ward (NR) 27-5; 3. Zytara Boyd (NR) 25-9; 4. Ashley Eldridge (STJ) 25-0 1/2; 5. Emily Ray (HA) 23-7.</div>
<div>PBL results -- 12. Sara Hewerdine, 17-9.</div>
<div>Discus</div>
<div>1. Makenna Ecker (PBL) 100-2; 2. Bethany Wyss (JEFF) 85-7; 3. Nevaeh Essien (JEFF) 73-10; 4. Reagan Weber (HA) 60-10; 5. Karena Mayfield (NR) 60-8.</div>
<div>PBL results -- T9. Sara Hewerdine, 49-3.</div>
<div>Pole vault</div>
<div>1. Taylor Henry (UNITY) 7-9; 2. Grace Schmitz (STJ) 6-9; 3. Macee Jensen (PBL) 6-3; 4. Hope Watts (PBL) 5-9; 5. Ruby Tarr (UNITY) 5-9.</div>
<div class="clear"></div>  </div>
      <div class="links">
      <ul class="links inline"><li class="print_html first"><a href="/print/1615165" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/print/icons/print_icon.gif" alt="Printer-friendly version" title="Printer-friendly version" width="16" height="16" class="print-icon" /></a></li>
<li class="service-links-facebook"><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;t=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Share on Facebook." class="service-links-facebook" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/facebook.png" alt="Facebook" title="" width="16" height="16" /></a></li>
<li class="service-links-twitter"><a href="http://twitter.com/share?url=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;text=PBL%20Junior%20High%20School%20track%20athletes%20compete%20at%20Unity%20Invite" title="Share this on Twitter" class="service-links-twitter" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/twitter.png" alt="Twitter" title="" width="16" height="16" /></a></li>
<li class="service-links-google"><a href="http://www.google.com/bookmarks/mark?op=add&amp;bkmk=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;title=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Bookmark this post on Google." class="service-links-google" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/google.png" alt="Google" title="" width="16" height="16" /></a></li>
<li class="service-links-yahoo"><a href="http://bookmarks.yahoo.com/myresults/bookmarklet?u=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;t=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Bookmark this post on Yahoo." class="service-links-yahoo" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/yahoo.png" alt="Yahoo" title="" width="16" height="16" /></a></li>
<li class="service-links-stumbleupon"><a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;title=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Thumb this up at StumbleUpon" class="service-links-stumbleupon" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/stumbleit.png" alt="StumbleUpon" title="" width="16" height="16" /></a></li>
<li class="service-links-reddit"><a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;title=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Submit this post on reddit.com." class="service-links-reddit" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/reddit.png" alt="Reddit" title="" width="16" height="16" /></a></li>
<li class="service-links-digg"><a href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;title=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Digg this post on digg.com" class="service-links-digg" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/digg.png" alt="Digg" title="" width="16" height="16" /></a></li>
<li class="service-links-delicious last"><a href="http://del.icio.us/post?url=http%3A%2F%2Fwww.paxtonrecord.net%2Fsports%2Fprep-sports%2F2018-05-05%2Fpbl-junior-high-school-track-athletes-compete-unity-invite.html&amp;title=PBL+Junior+High+School+track+athletes+compete+at+Unity+Invite" title="Bookmark this post on del.icio.us." class="service-links-delicious" rel="nofollow"><img src="http://www.paxtonrecord.net/sites/all/modules/contrib/service_links/images/delicious.png" alt="del.icio.us" title="" width="16" height="16" /></a></li>
</ul>    </div>
    <div class="meta">
          <div id="vocab-1615165-1-wrapper" class="vocab-wrapper"><span class="vocab-label">Categories (3):</span><span class="vocab-terms"><a href="/category/sports/prep-sports">Prep Sports</a>, <a href="/category/sports/prep-sports/track-and-field">Track and Field</a>, <a href="/category/sports">Sports</a></span></div>      </div>
      <div id="comment-info-wrapper">
      <h3>Comments</h3>
      <p><em>Comments for this post are inactive.</em></p>
    </div>
        </div>
                      </div><!--closes main-content-->
          
          <div id="right-column" class="span-8-minus last">
              <div id="block-block-47" class="block block-block region-odd even region-count-1 count-6">

  
  <div class="content"><!-- Paxton_Record_Sports --><div id="div-gpt-ad-1411058343082-0" style="width:300px; height:250px;"><script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1411058343082-0'); });
</script></div></div>
  
</div>
<div id="block-custom_blocks-0" class="block block-custom_blocks region-even odd region-count-2 count-7">

  
  <div class="content"><div id ="custom-blocks-dotd">
  <a href="http://www.news-gazette.com/store/deal-the-day" id="header-link" title="Deal of the Day" target="_blank"></a>  <h4><a href="http://www.news-gazette.com/store/deal-the-day/lake-the-woods-golf-two-90-45.html" target="_blank">Lake of the Woods Golf Course</a></h4>
  <div><a href="http://www.news-gazette.com/store/deal-the-day/lake-the-woods-golf-two-90-45.html" target="_blank">Buy a $90.00 certificate for only $45.00</a></div>
  <div id="stock-warning"></div>
  <div id="business-logo"><a href="http://www.news-gazette.com/store/deal-the-day/lake-the-woods-golf-two-90-45.html" title="Lake of the Woods Golf Course" target="_blank"><img src="http://www.paxtonrecord.net/sites/all/files/imagecache/200x125_width_height_scale/businesses/logos/lake_0.jpg" alt="Logo for " title="Logo for " width="151" height="85" class="imagecache imagecache-200x125_width_height_scale"/></a></div>
  <div class="custom-blocks-dotd-more">
        <ul>
          </ul>
    <!--<div class="center"><small>()</small></div>-->
    <!--<h5></h5>-->
    <!--<ul>
      <li></li>
      <li></li>
    </ul>-->
  </div>
</div></div>
  
</div>
          </div>   
        </div><!--closes content-wrapper-->
        <div id="feeder">
                  </div>
      </div><!--closes container-->
    </div><!-- closes wrapper -->
    
    <div class="nav-bar-wrapper">
      <div id="network-nav-bar-lower">
                  <div id="network-menu-lower">
                        <div id="block-menu-menu-menu-network-menu-lower" class="block block-menu region-odd even region-count-1 count-4">

  
  <div class="content"><ul class="menu"><li class="expanded first last"><a href="/" title="Our Sites">Our Sites</a><ul class="menu"><li class="expanded first"><a href="http://www.news-gazette.com/" title="News-Gazette">News-Gazette</a><ul class="menu"><li class="leaf first"><a href="http://digital.news-gazette.com/" title="Digital Services">Digital Services</a></li>
<li class="leaf last"><a href="http://www.news-gazette.com/eedition" title="e-Edition">e-Edition</a></li>
</ul></li>
<li class="leaf"><a href="http://www.illinihq.com" title="IlliniHQ.com">IlliniHQ</a></li>
<li class="leaf"><a href="http://www.wdws.com" title="NewsTalk 1400 WDWS-AM">NewsTalk 1400 WDWS-AM</a></li>
<li class="leaf"><a href="http://www.whms.com" title="Lite Rock 97.5 WHMS">Lite Rock 97.5 WHMS</a></li>
<li class="leaf"><a href="http://www.1079wkio.com" title="">107.9 WKIO</a></li>
<li class="expanded"><a href="http://www.news-gazette.com/news-gazette-community-newspapers.html" title="Community News">Community News</a><ul class="menu"><li class="leaf first"><a href="http://www.county-star.com" title="County Star">County Star</a></li>
<li class="leaf"><a href="http://www.the-independent-news.com" title="Independent News">Independent News</a></li>
<li class="leaf"><a href="http://www.leaderlandnews.com" title="The Leader">The Leader</a></li>
<li class="leaf"><a href="http://www.mcitizen.com" title="Mahomet Citizen">Mahomet Citizen</a></li>
<li class="leaf"><a href="http://www.paxtonrecord.net" title="Paxton Record">Paxton Record</a></li>
<li class="leaf"><a href="http://www.journal-republican.com" title="Piatt County Journal-Republican">Piatt County Journal-Republican</a></li>
<li class="leaf last"><a href="http://www.rantoulpress.com" title="Rantoul Press">Rantoul Press</a></li>
</ul></li>
<li class="expanded last"><a href="http://www.news-gazette.com/news-gazette-magazines.html" title="Magazines">Magazines</a><ul class="menu"><li class="leaf first"><a href="http://www.athomeillinois.com" title="At Home">At Home </a></li>
<li class="leaf last"><a href="http://www.centralillinoisbusiness.com" title="Central Illinois Business">Central Illinois Business</a></li>
</ul></li>
</ul></li>
</ul></div>
  
</div>
          </div><!--close network_menu-lower-->
                
         
         <ul class="social-network-icons">
                       <li><a href="http://www.facebook.com/pages/Paxton-Record/128840960595021"><img src="http://www.paxtonrecord.net/sites/all/themes/custom/cms_desktop/images/icons/facebook_icon.gif" alt="Facebook" /></a></li>
                               </ul>
              </div><!--closes nav-bar-->
    </div><!--/nav-bar-wrapper-->
    
    <div id="footer-area">
              <div id="footer" class="clear">
                      <div id="block-block-16" class="block block-block region-odd odd region-count-1 count-5">

  
  <div class="content"><div class="span-24">Contents of this site are <a href="/section/services/reader-services/copyright.html">Copyright © 2018 Paxton Record</a>. All rights reserved.<br /><a href="/sitemap/">Sitemap</a> | <a href="/section/services/online-services/news-gazette-online-privacy-policy.html">Privacy Policy</a> | <a href="/section/services/online-services/terms-use.html">Terms of Use</a> | <a href="/contact/">Contact Us</a> | <a href="/our-clients">Our Clients</a></div>
<div class="span-24"><a href="http://digital.news-gazette.com/web-design-development" target="_blank"><img alt=" Web Design/Development Champaign-Urbana" src="/sites/all/themes/custom/cms_960_desktop/images/digital_services_logo.png" /></a></div>
</div>
  
</div>
                            </div>
          </div><!--closes footer area-->
        <!-- Start Quantcast tag -->
		  <script type="text/javascript">
		    _qoptions={
		      qacct:"p-a15Hs4ofKGnVw"
		    };
		  </script>
		  <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
		  <noscript>
		    <img src="http://pixel.quantserve.com/pixel/p-a15Hs4ofKGnVw.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
		  </noscript>
		  <!-- End Quantcast tag -->  </body>
</html>